using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bwhere(?:(?:(?!where)[^][])*\[[^][]*])+\s*";
string substitution = @"";
string input = @"where this condition and [this = 1] group by 1,2,3
where that and that do that where [this = 1] and [that = 1] group by 1,2,3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}