use strict;
my $str = 'where this condition and [this = 1] group by 1,2,3
where that and that do that where [this = 1] and [that = 1] group by 1,2,3';
my $regex = qr/\bwhere(?:(?:(?!where)[^][])*\[[^][]*])+\s*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";