# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)//gm;t' <<< "20191107 - @#$%^& This is a section - 20191107"