$re = '/([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)/m';
$str = '20191107 - @#$%^& This is a section - 20191107';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;