package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)`)
var str = `20191107 - @#$%^& This is a section - 20191107`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}