use strict;
my $str = '20191107 - @#$%^& This is a section - 20191107';
my $regex = qr/([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";