// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)").unwrap();
let string = "20191107 - @#$%^& This is a section - 20191107";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}