const regex = /([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w-]+$)|([\\w-]+)|([-\\s]+)|([^\\w]+)', 'gm')
const str = `20191107 - @#\$%^& This is a section - 20191107`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);