#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)"
Local $sString = "20191107 - @#$%^& This is a section - 20191107"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)