using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)";
string substitution = @"";
string input = @"20191107 - @#$%^& This is a section - 20191107";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}