re = /([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)/m
str = '20191107 - @#$%^& This is a section - 20191107'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result