import Foundation
let pattern = #"([\w-]+$)|([\w-]+)|([-\s]+)|([^\w]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"20191107 - @#$%^& This is a section - 20191107"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)