#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:([A-Z]{2})|[A-Z]*)(\d{6,14})([A-Z]\d?$)?"
Local $sString = "US20635879356A1" & @CRLF & _
"US20175478285A2" & @CRLF & _
"US20555632199A1" & @CRLF & _
"US20287543790K6" & @CRLF & _
"US2018870A1" & @CRLF & _
"EP3277423683A1" & @CRLF & _
"EP3610231A2" & @CRLF & _
"US20220082440A" & @CRLF & _
"EP3610231B" & @CRLF & _
"" & @CRLF & _
"US2016666350AK" & @CRLF & _
"U20457883B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")