import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:([A-Z]{2})|[A-Z]*)(\\d{6,14})([A-Z]\\d?$)?";
final String string = "US20635879356A1\n"
+ "US20175478285A2\n"
+ "US20555632199A1\n"
+ "US20287543790K6\n"
+ "US2018870A1\n"
+ "EP3277423683A1\n"
+ "EP3610231A2\n"
+ "US20220082440A\n"
+ "EP3610231B\n\n"
+ "US2016666350AK\n"
+ "U20457883B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}