// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:([A-Z]{2})|[A-Z]*)(\d{6,14})([A-Z]\d?$)?").unwrap();
let string = "US20635879356A1
US20175478285A2
US20555632199A1
US20287543790K6
US2018870A1
EP3277423683A1
EP3610231A2
US20220082440A
EP3610231B
US2016666350AK
U20457883B";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}