re = /^(?:([A-Z]{2})|[A-Z]*)(\d{6,14})([A-Z]\d?$)?/m
str = 'US20635879356A1
US20175478285A2
US20555632199A1
US20287543790K6
US2018870A1
EP3277423683A1
EP3610231A2
US20220082440A
EP3610231B
US2016666350AK
U20457883B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end