package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([A-Z]{2})|[A-Z]*)(\d{6,14})([A-Z]\d?$)?`)
var str = `US20635879356A1
US20175478285A2
US20555632199A1
US20287543790K6
US2018870A1
EP3277423683A1
EP3610231A2
US20220082440A
EP3610231B
US2016666350AK
U20457883B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}