const regex = /^(?:([A-Z]{2})|[A-Z]*)(\d{6,14})([A-Z]\d?$)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([A-Z]{2})|[A-Z]*)(\\d{6,14})([A-Z]\\d?$)?', 'gm')
const str = `US20635879356A1
US20175478285A2
US20555632199A1
US20287543790K6
US2018870A1
EP3277423683A1
EP3610231A2
US20220082440A
EP3610231B
US2016666350AK
U20457883B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}