# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:([A-Z]{2})|[A-Z]*)(\d{6,14})([A-Z]\d?$)?"
test_str = ("US20635879356A1\n"
"US20175478285A2\n"
"US20555632199A1\n"
"US20287543790K6\n"
"US2018870A1\n"
"EP3277423683A1\n"
"EP3610231A2\n"
"US20220082440A\n"
"EP3610231B\n\n"
"US2016666350AK\n"
"U20457883B")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.