using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([A-Z]{2})|[A-Z]*)(\d{6,14})([A-Z]\d?$)?";
string input = @"US20635879356A1
US20175478285A2
US20555632199A1
US20287543790K6
US2018870A1
EP3277423683A1
EP3610231A2
US20220082440A
EP3610231B
US2016666350AK
U20457883B";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}