# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:john|jack|heather)\b/test/g;t' <<< "john //match
jack //match
heather //match
wheather //not match
hijack //not match
johnny //not match"