$re = '/\b(?:john|jack|heather)\b/';
$str = 'john //match
jack //match
heather //match
wheather //not match
hijack //not match
johnny //not match';
$subst = "test";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;