const regex = /\b(?:john|jack|heather)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:john|jack|heather)\\b', 'g')
const str = `john //match
jack //match
heather //match
wheather //not match
hijack //not match
johnny //not match`;
const subst = `test`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);