package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:john|jack|heather)\b`)
var str = `john //match
jack //match
heather //match
wheather //not match
hijack //not match
johnny //not match`
var substitution = "test"
fmt.Println(re.ReplaceAllString(str, substitution))
}