#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?:john|jack|heather)\b"
Local $sString = "john //match" & @CRLF & _
"jack //match" & @CRLF & _
"heather //match" & @CRLF & _
"wheather //not match" & @CRLF & _
"hijack //not match" & @CRLF & _
"johnny //not match"
Local $sSubst = "test"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)