import Foundation
let pattern = #"\b(?:john|jack|heather)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
john //match
jack //match
heather //match
wheather //not match
hijack //not match
johnny //not match
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"test"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)