use strict;
my $str = 'john //match
jack //match
heather //match
wheather //not match
hijack //not match
johnny //not match';
my $regex = qr/\b(?:john|jack|heather)\b/p;
my $subst = 'test';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";