re = /\b(?:john|jack|heather)\b/
str = 'john //match
jack //match
heather //match
wheather //not match
hijack //not match
johnny //not match'
subst = 'test'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result