import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:john|jack|heather)\\b";
final String string = "john //match\n"
+ "jack //match\n"
+ "heather //match\n"
+ "wheather //not match\n"
+ "hijack //not match\n"
+ "johnny //not match";
final String subst = "test";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}