using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:john|jack|heather)\b";
string substitution = @"test";
string input = @"john //match
jack //match
heather //match
wheather //not match
hijack //not match
johnny //not match";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}