$re = '`^/[a-zA-Z0-9]+/wp-`m';
$str = '/abc/wp-config.php
/123/wp-config.php';
$subst = "/wp-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;