re = /^\/[a-zA-Z0-9]+\/wp-/m
str = '/abc/wp-config.php
/123/wp-config.php'
subst = '/wp-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result