#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\[+[A-Z\d-]+:\s*(.*?)\s*]+$"
Local $sString = "[ABC1: text1]" & @CRLF & _
"[[DC: this is a text]]" & @CRLF & _
"[ABC-O: potatoes]" & @CRLF & _
"[[C-DF: hello]]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)