$re = '`^\[+[A-Z\d-]+:\s*(.*?)\s*]+$`m';
$str = '[ABC1: text1]
[[DC: this is a text]]
[ABC-O: potatoes]
[[C-DF: hello]]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;