import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[+[A-Z\\d-]+:\\s*(.*?)\\s*]+$";
final String string = "[ABC1: text1]\n"
+ "[[DC: this is a text]]\n"
+ "[ABC-O: potatoes]\n"
+ "[[C-DF: hello]]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}