re = /^\[+[A-Z\d-]+:\s*(.*?)\s*]+$/m
str = '[ABC1: text1]
[[DC: this is a text]]
[ABC-O: potatoes]
[[C-DF: hello]]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result