package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[+[A-Z\d-]+:\s*(.*?)\s*]+$`)
var str = `[ABC1: text1]
[[DC: this is a text]]
[ABC-O: potatoes]
[[C-DF: hello]]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}