use strict;
my $str = '[ABC1: text1]
[[DC: this is a text]]
[ABC-O: potatoes]
[[C-DF: hello]]';
my $regex = qr`^\[+[A-Z\d-]+:\s*(.*?)\s*]+$`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";