import Foundation
let pattern = #"^\[+[A-Z\d-]+:\s*(.*?)\s*]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[ABC1: text1]
[[DC: this is a text]]
[ABC-O: potatoes]
[[C-DF: hello]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)