const regex = new RegExp('^\\[+[A-Z\\d-]+:\\s*(.*?)\\s*]+$', 'gm')
const str = `[ABC1: text1]
[[DC: this is a text]]
[ABC-O: potatoes]
[[C-DF: hello]]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);