# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bcp\h+(filename\d+)\*(\.csv)/$0 $1$2/gm;t' <<< "cp filename1*.csv
cp filename2*.csv
cp filename3*.csv
"