$re = '/\bcp\h+(filename\d+)\*(\.csv)/m';
$str = 'cp filename1*.csv
cp filename2*.csv
cp filename3*.csv
';
$subst = "$0 $1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;