import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bcp\\h+(filename\\d+)\\*(\\.csv)";
final String string = "cp filename1*.csv \n"
+ "cp filename2*.csv \n"
+ "cp filename3*.csv \n";
final String subst = "$0 $1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}