use strict;
my $str = 'cp filename1*.csv
cp filename2*.csv
cp filename3*.csv
';
my $regex = qr/\bcp\h+(filename\d+)\*(\.csv)/mp;
my $subst = '$0 $1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";