package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bcp\h+(filename\d+)\*(\.csv)`)
var str = `cp filename1*.csv
cp filename2*.csv
cp filename3*.csv
`
var substitution = "$0 $1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}