import Foundation
let pattern = #"\bcp\h+(filename\d+)\*(\.csv)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cp filename1*.csv
cp filename2*.csv
cp filename3*.csv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0 $1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)