// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bcp\h+(filename\d+)\*(\.csv)").unwrap();
let string = "cp filename1*.csv
cp filename2*.csv
cp filename3*.csv
";
let substitution = "$0 $1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}