#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bcp\h+(filename\d+)\*(\.csv)"
Local $sString = "cp filename1*.csv " & @CRLF & _
"cp filename2*.csv " & @CRLF & _
"cp filename3*.csv " & @CRLF & _
""
Local $sSubst = "$0 $1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)