re = /\bcp\h+(filename\d+)\*(\.csv)/m
str = 'cp filename1*.csv
cp filename2*.csv
cp filename3*.csv
'
subst = '$0 $1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result