# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<SimpleData name=")NAME(">[\S\s\n]*?<\/SimpleData>)/$1COUNTY$2/gm;t' <<< "<SimpleData name=\"NAME\">Angelina</SimpleData>"